Cant find steam under chinese dota 2 launcher

dcnbdcnb Posts: 15

Ive posted a same thread under chinese section but no techinal support yet. So the loader cant detect steam nor the core thus i cant start dota2 thru the loader.

Tagged:

Comments

  • octocatoctocat Posts: 10

    I heard @Zynox is working on it.

  • dcnbdcnb Posts: 15

    ty for the good news guess ill just wait.

  • likereallylikereally Posts: 4
    edited April 2017

    @dcnb said:
    ty for the good news guess ill just wait.

    It always helps to attach your Loader logs which can be found in the "Logs" folder.
    Also the chinese "steam" client is called "dota2launcher", isn't it?

  • dcnbdcnb Posts: 15

    @likereally 说道:

    @dcnb said:
    ty for the good news guess ill just wait.

    It always helps to attach your Loader logs which can be found in the "Logs" folder.
    Also the chinese "steam" client is called "dota2launcher", isn't it?

    ty for the instructions these r the 4 logs in the folder. the old ensage can always detect game version and core version while dota2launcher is running before the injection.

  • GoldenfrozeGoldenfroze Posts: 859

    @dcnb said:
    Ive posted a same thread under chinese section but no techinal support yet. So the loader cant detect steam nor the core thus i cant start dota2 thru the loader.

    set it here C:\Program Files (x86)\Steam\steamapps\common\dota 2 beta\game\bin\win64

  • dcnbdcnb Posts: 15

    @Goldenfroze 说道:

    @dcnb said:
    Ive posted a same thread under chinese section but no techinal support yet. So the loader cant detect steam nor the core thus i cant start dota2 thru the loader.

    set it here C:\Program Files (x86)\Steam\steamapps\common\dota 2 beta\game\bin\win64

    set the loader there? or the game?

  • GoldenfrozeGoldenfroze Posts: 859

    @dcnb said:

    @Goldenfroze 说道:

    @dcnb said:
    Ive posted a same thread under chinese section but no techinal support yet. So the loader cant detect steam nor the core thus i cant start dota2 thru the loader.

    set it here C:\Program Files (x86)\Steam\steamapps\common\dota 2 beta\game\bin\win64

    set the loader there? or the game?

    if you press the start dota I will ask for steam right/
    then a box will pop up u need to go that and find dota.exe with I give the location.

  • GoldenfrozeGoldenfroze Posts: 859

    if still u don't get it PM me I will do it for you via tv.

  • dcnbdcnb Posts: 15

    @Goldenfroze 说道:
    if still u don't get it PM me I will do it for you via tv.

    yes i noticed the prompt and i managed to locate the dota2exe but it starts under global server environment not chinese server environment.

  • dcnbdcnb Posts: 15

    and i cant play with friends who on chinese server the game just couldnt load the map after picking hero interface.

  • GoldenfrozeGoldenfroze Posts: 859

    I have the chinese server but I can't play it because Im not in china.

  • dcnbdcnb Posts: 15

    this is still global server my chinese server looks like this

  • dcnbdcnb Posts: 15

    this is the interface i get thru perfect world's dota2launcher just china cable providers on the list

  • dcnbdcnb Posts: 15

    i figure chinese server is seperated cuz my friend cant play on sea or japan server either

  • GoldenfrozeGoldenfroze Posts: 859

    @dcnb said:
    i figure chinese server is seperated cuz my friend cant play on sea or japan server either

    yes its seperated but you can still use ensage on that china server. :)

  • ultiworldultiworld Posts: 65

    @Goldenfroze said:

    @dcnb said:
    i figure chinese server is seperated cuz my friend cant play on sea or japan server either

    yes its seperated but you can still use ensage on that china server. :)

    Can we make it like the old ensage so it can auto detect and inject when we open dota2 ourself?

  • dcnbdcnb Posts: 15

    @Zynox help us out plz!

  • dcnbdcnb Posts: 15

    Solved! To use the Chinese environment you have to add -perfectworld on the "Launch options" setting.

  • @dcnb said:
    Solved! To use the Chinese environment you have to add -perfectworld on the "Launch options" setting.

    can confirm that it's working

  • GoldenfrozeGoldenfroze Posts: 859

    @Eeveelutions said:

    @dcnb said:
    Solved! To use the Chinese environment you have to add -perfectworld on the "Launch options" setting.

    can confirm that it's working

    Confirmed Its working.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!