Terminated User Process

ceferinoceferino Posts: 2

I Need Help last 3 hrs i use it and this error Come Out and Close Dota2



  • hawk027hawk027 Posts: 20

    are you using "start Dota2" button? if yes it should work fine

  • ceferinoceferino Posts: 2

    yes i always do but it wont load the game that thing show up every time i lunch the game i already try 6-10 times to load the game using " start dota2 " even i restart the PC and Re download the Apps ..

  • ceferino2ceferino2 Posts: 1

    I create new Account ensage to try whats the problem and i can see still the same i cant Lunch the Game Using Loader and cant Lunch the game Using Steam ether .. Any one can Help me

  • neverb4dneverb4d Posts: 1

    same issues here

  • NeeDforKillNeeDforKill Posts: 1,976

    @neverb4d said:
    same issues here

    any Razer stuff?

  • GoldenfrozeGoldenfroze Posts: 890

    Close razer synapse and make sure your lobby created has server not local host.

  • same issues

  • did u install it on your main drive? please make sure you install it on your main drive and not in downloads.
    and you should start the dota 2 via ensage in the loader Dashboard you can see the Start Dota 2 button and if still not working try select dx9.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!